NOTICE: NSDMS Logon Error
Incident Report for The merSETA
Resolved
This incident has been resolved.
Posted Mar 28, 2023 - 14:40 SAST
Investigating
Afternoon all

Kindly note that we are investigating the cause of the error users are experiencing when trying to log on to the NSDMS, we will provide an update on the progress shortly.

Regards,
Posted Mar 28, 2023 - 14:16 SAST
This incident affected: NSDMS Related Services (NSDMS Web Application).