NOTICE: merSETA website
Incident Report for The merSETA
Resolved
This incident has been resolved.
Posted Mar 20, 2023 - 11:32 SAST
Investigating
Good day colleagues

Please note that the website is currently unreachable at the moment; we are working on resolving this issue and will advise colleagues on the progress.

Regards,
MIS
Posted Mar 20, 2023 - 10:11 SAST
This incident affected: merSETA Website.