NSDMS Connection Issues

Incident Report for The merSETA

Resolved

This incident has been resolved.
Posted Apr 01, 2025 - 20:15 SAST

Identified

Dear valued stakeholder,

Kindly note that NSDMS is currently experiencing intermittent connection issues and users may experience navigation issues on the system. Our team is actively working to resolve the issue urgently, and further updates will be provided in due course.
Posted Apr 01, 2025 - 15:24 SAST
This incident affected: NSDMS Related Services (NSDMS Web Application).