NOTICE: NOTICE: NSDMS Connectivity

Incident Report for The merSETA

Resolved

This incident has been resolved.
Posted Nov 25, 2025 - 14:45 SAST

Investigating

Good day colleagues

Please note that NSDMS is experiencing unusually high traffic which has negatively impacted response time to login. We are attending to this issue and we will advise on progress.
Posted Nov 25, 2025 - 13:48 SAST
This incident affected: NSDMS Related Services (NSDMS Web Application).