UPDATE: merSETA Website
Incident Report for The merSETA
Resolved
This incident has been resolved.
Posted Mar 20, 2023 - 18:33 SAST
Identified
Good day all

Kindly note that we are still working on resolving the earlier reported issue affecting the website, we will keep you updated on progress in due course. Thank you

Regards,
Posted Mar 20, 2023 - 12:07 SAST
This incident affected: merSETA Website.