merSETA Website SSL Certificate Issues
Incident Report for The merSETA
Resolved
This incident has been resolved.
Posted Nov 21, 2023 - 11:03 SAST
Update
We are continuing to work on a fix for this issue.
Posted Nov 20, 2023 - 15:36 SAST
Update
We are continuing to work on a fix for this issue.
Posted Nov 20, 2023 - 12:31 SAST
Identified
Good day

Please note that we are working on resolving an issue picked on the website SSL certificate, we will update on the progress shortly.
Posted Nov 20, 2023 - 09:12 SAST
This incident affected: merSETA Website.