NSDMS ID validation notice
Incident Report for The merSETA
Resolved
This incident has been resolved.
Posted May 09, 2023 - 08:43 SAST
Investigating
Good day all

Please see below the notice on current challenges experienced on integration that handles ID validations on NSDMS. We will keep you updated on progress as soon as we receive an update on the progress of maintenance and restoration of services.
Posted May 08, 2023 - 15:16 SAST
This incident affected: NSDMS Related Services (PBSA Home Affairs Webservice).