NOTICE: NOTICE: NSDMS Saving of records

Incident Report for The merSETA

Resolved

This incident has been resolved.
Posted Mar 13, 2026 - 14:49 SAST

Update

We are continuing to work on a fix for this issue.
Posted Mar 13, 2026 - 13:08 SAST

Update

We are continuing to work on a fix for this issue.
Posted Mar 13, 2026 - 07:31 SAST

Update

We are continuing to work on a fix for this issue.
Posted Mar 12, 2026 - 14:08 SAST

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 12, 2026 - 11:40 SAST

Update

We are continuing to investigate this issue.
Posted Mar 11, 2026 - 13:52 SAST

Investigating

Good day

We are currently investigating issue related to searching and saving of certain information on the NSDMS. We will keep you posted on progress of this issue.
Posted Mar 11, 2026 - 12:53 SAST
This incident affected: NSDMS Related Services (NSDMS Web Application).